ошибка PHP

Ответить
Аватара пользователя
Oleg
Сообщения: 470
Зарегистрирован: 26 окт 2018, 08:23
Имя: Олег Родионов
Откуда: Россия,Санкт-Петербург

ошибка PHP

Сообщение Oleg »

при установке версии 2.4 выскакивает ошибка
Please fix following errors.
PHP ZIP extension is NOT installed on your web server
Хотя PHP ZIP стоит
rpm -qa | grep php
php-xml-7.2.13-2.el7.remi.x86_64
php-pecl-msgpack-2.0.3-1.el7.remi.7.2.x86_64
php-7.2.13-2.el7.remi.x86_64
php-odbc-7.2.13-2.el7.remi.x86_64
php-pecl-geoip-1.1.1-4.el7.remi.7.2.x86_64
php-intl-7.2.13-2.el7.remi.x86_64
php72-runtime-1.0-1.el7.remi.x86_64
php72-php-pecl-zip-1.15.4-1.el7.remi.x86_64
php-fedora-autoloader-1.0.0-1.el7.noarch
php-common-7.2.13-2.el7.remi.x86_64
php-pdo-7.2.13-2.el7.remi.x86_64
php-pecl-igbinary-2.0.8-1.el7.remi.7.2.x86_64
php-process-7.2.13-2.el7.remi.x86_64
php-pear-1.10.7-3.el7.remi.noarch
php-pecl-redis4-4.2.0-1.el7.remi.7.2.x86_64
php-mysqlnd-7.2.13-2.el7.remi.x86_64
php-mbstring-7.2.13-2.el7.remi.x86_64
php-ldap-7.2.13-2.el7.remi.x86_64
php-gd-7.2.13-2.el7.remi.x86_64
php-fpm-7.2.13-2.el7.remi.x86_64
php72-php-json-7.2.13-2.el7.remi.x86_64
php-json-7.2.13-2.el7.remi.x86_64
php-cli-7.2.13-2.el7.remi.x86_64
php-pecl-memcached-3.1.2-1.el7.remi.7.2.x86_64
php-xmlrpc-7.2.13-2.el7.remi.x86_64
php-imap-7.2.13-2.el7.remi.x86_64
php-pecl-mcrypt-1.0.1-6.el7.remi.7.2.x86_64
php72-php-common-7.2.13-2.el7.remi.x86_64
OS Centos7
Установка и настройка IP ATC Asterisk
Аватара пользователя
support
Техническая поддержка
Сообщения: 9068
Зарегистрирован: 19 окт 2014, 18:22
Имя: Харчишин Сергей
Откуда: Крым, Евпатория

Re: ошибка PHP

Сообщение support »

При установке выполняется следующая проверка

Код: Выделить всё

if(!extension_loaded("zip"))
Аватара пользователя
Oleg
Сообщения: 470
Зарегистрирован: 26 окт 2018, 08:23
Имя: Олег Родионов
Откуда: Россия,Санкт-Петербург

Re: ошибка PHP

Сообщение Oleg »

назад откатываешься на 2.3.1 и все зависимости нормально в том числе и php zip
Установка и настройка IP ATC Asterisk
Аватара пользователя
support
Техническая поддержка
Сообщения: 9068
Зарегистрирован: 19 окт 2014, 18:22
Имя: Харчишин Сергей
Откуда: Крым, Евпатория

Re: ошибка PHP

Сообщение support »

Ранее этой проверки не было...
Гляньте тут http://php.net/manual/ru/zip.installation.php
Аватара пользователя
Oleg
Сообщения: 470
Зарегистрирован: 26 окт 2018, 08:23
Имя: Олег Родионов
Откуда: Россия,Санкт-Петербург

Re: ошибка PHP

Сообщение Oleg »

все заработало, может кому пригодиться
испльзуем репозитарий remi (должен быть установлен).
yum --enablerepo=remi install libzip-last libzip-last-devel php-devel
pecl install zip
vi /etc/php.ini
в секцию [PHP] добавляем строчку: extension=zip.so
systemctl restart httpd
это для OS Centos 7.
Установка и настройка IP ATC Asterisk
sanys
Сообщения: 118
Зарегистрирован: 30 май 2017, 12:52
Имя: Александр
Откуда: Казахстан

Re: ошибка PHP

Сообщение sanys »

Напишу сюда.
Чистая установка на сервер с ubuntu 18.04 по этой инструкции (только версия 2.4.1).
После запуска http сервера и входа на страницу выдает
"Библиотека PHP CURL не установлена ​​на вашем веб-сервере"
"Библиотека PHP XML не установлена ​​на вашем веб-сервере"

Установлено:

Код: Выделить всё

# dpkg -l | grep php
libapache2-mod-php    
libapache2-mod-php7.2 
php                   
php-common            
php-curl              
php-gd                
php-mbstring          
php-mysql             
php-remctl            
php-xml               
php-zip               
php7.2                
php7.2-cli            
php7.2-common         
php7.2-curl           
php7.2-gd             
php7.2-json           
php7.2-mbstring       
php7.2-mysql          
php7.2-opcache        
php7.2-phpdbg         
php7.2-readline       
php7.2-xml            
php7.2-zip
Аватара пользователя
support
Техническая поддержка
Сообщения: 9068
Зарегистрирован: 19 окт 2014, 18:22
Имя: Харчишин Сергей
Откуда: Крым, Евпатория

Re: ошибка PHP

Сообщение support »

Откройте файл install\modules\checking_environment.php и удалите код

Код: Выделить всё

//check zip
  if(!extension_loaded("zip"))
  {
  	$error_list[] = TEXT_ERROR_ZIP_LIB;
  }
  
  //check zip
  if(!extension_loaded("xml"))
  {
  	$error_list[] = TEXT_ERROR_XML_LIB;
  }
sanys
Сообщения: 118
Зарегистрирован: 30 май 2017, 12:52
Имя: Александр
Откуда: Казахстан

Re: ошибка PHP

Сообщение sanys »

support писал(а): 08 фев 2019, 20:48 Откройте файл install\modules\checking_environment.php и удалите код

Код: Выделить всё

//check zip
  if(!extension_loaded("zip"))
  {
  	$error_list[] = TEXT_ERROR_ZIP_LIB;
  }
  
  //check zip
  if(!extension_loaded("xml"))
  {
  	$error_list[] = TEXT_ERROR_XML_LIB;
  }
Уже хотел было так делать, но решилось простой перезагрузкой сервера.
alexey23
Сообщения: 3
Зарегистрирован: 07 май 2019, 08:59
Имя: Алексей
Откуда: Россия

Re: ошибка PHP

Сообщение alexey23 »

Добрый день!! У меня после удаления строчек исчезла ошибка об XML. PHP Curl всё так же не установлена!!что делать?
Ответить